【已解决】PDF++ 插件总是弹出提示 Outdated Obsidian installer(需 Ob 安装程序版本符合要求,即需要下载 Ob 安装包重新安装更新)


哈哈哈,或许作者开发时,不兼容是需要升级到最新版,但现在不兼容恰恰是因为最新版 :rofl:

pdf++,我也是升级到最新版的,

你看看pdf++发布时间是ob1.6x发布之前还是之后

同样的obsidian版本,重新安装后,pdf++就正常了,有点古怪。

哈哈哈,引用“程序员吐槽大会”的一句话,80%的问题通过重启可以解决,剩下20%不用解决,并不是所有问题都能解决的。 :rofl:

从官网下载最新的软件包,重新安装一下就没了,插件的问题

看人家的提示信息, 不是要求ob最新版, 而是要求ob安装包是最新版.
类比就是, 你的操作系统从win10自动升级到win11, 不行, 必须直接用win11安装包. 至于为啥需要这样, 就不知道了.

貌似是因为 Electron 版本是必须要通过安装程序才能更新的,所以要看安装程序版本 Installer version 是否符合要求,而不能看当前版本 Current version。